Delay in data collection
Incident Report for CoverageBook
Resolved
This incident has been resolved.
Posted Jan 07, 2022 - 15:32 UTC
Identified
We're experiencing longer than usual upload times and are working through those as quickly as we can.
Posted Jan 07, 2022 - 14:57 UTC
This incident affected: Data and Metrics.