Delay in data collection
Incident Report for CoverageBook
Resolved
The issue with data collection has now been resolved, please get in touch with our support team if you have any questions.
Posted Nov 09, 2020 - 13:52 UTC
Investigating
We are investigating an issue which could cause delays in data collection. Sorry about this, we'll update as soon as possible. If you have any questions please get in touch at support@coveragebook.com.
Posted Nov 09, 2020 - 13:44 UTC
This incident affected: Data and Metrics.