Issue with Twitter embedded images
Incident Report for CoverageBook
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 11:17 UTC
Investigating
Our provider for Twitter embeds is having some intermittent issues. We're looking into this and will update as soon as we have more information. Apologies for any inconvenience, please get in touch at support@coveragebook.com if you have any questions.
Posted Jun 30, 2020 - 10:24 UTC
This incident affected: Image collection and uploading.