CoverageBook - intermittent downtime
Incident Report for CoverageBook
Resolved
The issue has been resolved and CoverageBook is now operational. If you have any questions on this please get in touch at support@coveragebook.com
Posted Jan 07, 2020 - 13:17 UTC
Investigating
We're currently experiencing some intermittent downtime with CoverageBook and are working to get this fixed as soon as possible. We're sorry about this and will update once it has been resolved.
Posted Jan 07, 2020 - 13:07 UTC
This incident affected: Application.