Issues with Estimated coverage views and domain authority
Incident Report for CoverageBook
Resolved
The issue with estimated views and DA data not showing in some books has been resolved. If you have any further issues or queries please get in touch with us at support@coveragebook.com or through the chat messenger when logged in.
Posted Mar 02, 2020 - 15:35 UTC
Monitoring
Update - We're starting to get new data come through from Moz, and you should now see estimated views and DA scores showing in your books. We'll continue to monitor this until full service has resumed. Apologies again for any inconvenience caused. If you have any questions please get in touch at support@coveragebook.com, or through the chat messenger when logged into your account.
Posted Mar 02, 2020 - 13:25 UTC
Investigating
Moz (our provider for domain authority) are currently experiencing technical issues and we're unable to collect DA scores for online articles. This will also affect estimated coverage views data. We're very sorry about this. We'll continue to monitor the issue with Moz and will keep you updated.
Posted Mar 02, 2020 - 10:06 UTC
This incident affected: Data and Metrics.