Insights Menu Unavailable
Incident Report for CoverageBook
Resolved
The temporary issue with the Insights Menu has been resolved and it's now available. Apologies for any inconvenience caused. if you have any questions please get in touch at support@coveragebook/com.
Posted 4 months ago. May 29, 2019 - 11:54 UTC
Update
We are continuing to work on a fix for this issue.
Posted 4 months ago. May 29, 2019 - 11:22 UTC
Identified
We are currently investigating an issue with the Insights Menu. We're sorry about this, and hope to have it resolved soon. If you have any queries in the meantime please contact support@coveragebook.com
Posted 4 months ago. May 29, 2019 - 11:21 UTC
This incident affected: Application.