Delays with data collection
Incident Report for CoverageBook
Resolved
This incident has now been resolved, if you have any questions please get in touch.
Posted Mar 31, 2021 - 18:31 UTC
Investigating
Some coverage uploads may have delays in the data coming through, we're sorry for any inconvenience caused and will update when this is resolved. If you have any questions we'd be happy to help at support@coveragebook.com
Posted Mar 31, 2021 - 15:57 UTC
This incident affected: Data and Metrics.