CoverageBook temporarily down.
Incident Report for CoverageBook
Resolved
This incident has been resolved.
Posted Jul 23, 2021 - 09:32 UTC
Monitoring
and we're back. down for about 60 seconds. Sorry about that! Get in touch with support if you have any concerns.
Posted Jul 23, 2021 - 08:57 UTC
Investigating
We're aware that some customers are unable to login to CoverageBook right now. We're investigating and working on a fix. We're so sorry for the inconvenience.
Posted Jul 23, 2021 - 08:55 UTC
This incident affected: Application.