Uploading coverage - online and offline items.
Incident Report for CoverageBook
Resolved
We've resolved the issue with screenshots and data not showing in some customer's books. Please accept our apologies for this. If you have any questions we'd be happy to help, please contact us at support@coveragebook.com or through the chat messenger when logged in.
Posted Jan 17, 2020 - 11:03 UTC
Investigating
Some customers may experience issues with screenshots and data when uploading online and offline coverage. We're sorry about this and are working to resolve it as soon as possible.
Posted Jan 17, 2020 - 09:30 UTC
This incident affected: Data and Metrics and Image collection and uploading.