Issues with the insights page
Incident Report for CoverageBook
Resolved
This incident has been resolved.
Posted May 28, 2021 - 12:04 UTC
Update
We are continuing to monitor for any further issues.
Posted May 28, 2021 - 12:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 28, 2021 - 11:34 UTC
Investigating
Some customers may have issues accessing the insights view, we're currently working to resolve this issue.
Posted May 28, 2021 - 11:15 UTC
This incident affected: Application.