Issue with books getting stuck and slow loading of pages.
Incident Report for CoverageBook
Resolved
This incident is now resolved.
Posted 3 months ago. May 02, 2019 - 07:35 UTC
Investigating
We are currently investigating some pieces of coverage taking longer than usual getting screenshots and metrics. This is also having an affect on offline coverage.
There is also an issue with slow web response times.
We are working on fixing these issues now and we hope to have a normal service resumed asap.
Posted 3 months ago. May 02, 2019 - 07:03 UTC
This incident affected: Application, Data and Metrics, and Image collection and uploading.