Back to overview
Degraded

Delays with data processing

Aug 07 at 03:34pm BST
Affected services
Application

Resolved
Aug 08 at 10:43am BST

We're back to normal service after some delays in data processing over the last 24 hours. If you have any questions please get in touch with us at support@coveragebook.com

Created
Aug 07 at 03:34pm BST

We're experiencing some delays in data processing and are investigating. Sorry for any inconvenience caused, we'll update as soon as possible.