Back to overview
Degraded

Issues accessing CoverageBook

Aug 14 at 02:28pm BST
Affected services
Application
Data Collection

Resolved
Aug 15 at 10:03am BST

We're back to normal service after having some intermittent outages yesterday, apologies again for any inconvenience, if you have any questions please get in touch at support@coveragebook.com

Updated
Aug 14 at 05:12pm BST

We have identified the issue and are monitoring, we'll update as soon as we're back to normal service levels. Apologies again for this.

Created
Aug 14 at 02:28pm BST

Some customers might see slower speeds or have some issues accessing CoverageBook. We're working on it and will update as soon as we can. We're very sorry for this, if you have any questions please get in touch at support@coveragebook.com