Back to overview
Downtime

CoverageBook is unavailable

Nov 08 at 03:51pm GMT
Affected services
Application

Resolved
Nov 08 at 03:59pm GMT

CoverageBook is now available again. Thanks for your patience while we resolved this issue!

Created
Nov 08 at 03:51pm GMT

CoverageBook is currently unavailable. We're working to resolve this issue asap and we'll update you as soon as we can.