Back to overview
Degraded

Images for new imports are currently delayed

Jan 02 at 04:15pm GMT
Affected services
Application

Resolved
Jan 02 at 05:58pm GMT

We have resolved the issue and imports will now work as expected. Apologies for any inconvenience caused.

Created
Jan 02 at 04:15pm GMT

Currently when importing new coverage, the screenshot will take much longer than usual to be shown. We're working to get this resolved asap and will update once this has returned to normal.