Back to overview
Degraded
CoverageBook is currently unable to display some images
Jan 03 at 08:57am GMT
Affected services
Application
Resolved
Jan 03 at 09:41am GMT
We have now resolved the issue and image will display as normal.
Affected services
Application
Created
Jan 03 at 08:57am GMT
We're currently working to fix an issue where some images are not displaying correctly. We're really sorry for the inconvenience caused and will work to restore normal service asap.
Affected services
Application