Back to overview
Degraded

Imports are slower than usual

Feb 06 at 04:54pm GMT
Affected services
Application

Resolved
Feb 06 at 05:38pm GMT

We have completed the fix and the site is now working normally. Really sorry for any inconvenience caused by the delay.

Updated
Feb 06 at 05:34pm GMT

The ongoing issue is causing the site to become temporarily unavailable. We're working to resolve the issue as soon as we can.

Created
Feb 06 at 04:54pm GMT

We currently have an issue which is causing coverage to be imported much slower than usual. We are really sorry for the inconvenience caused and are working to restore normal service asap.