Back to overview
Degraded
Delays in coverage imports
Jul 08 at 04:51pm BST
Affected services
Application
Data Collection
Resolved
Jul 08 at 06:15pm BST
Imports are now working as usual, we'll continue to monitor, if you have any questions or need help with a report please email a link to the report and details to support@coveragebook.com and we'll reply as soon as we can.
Affected services
Application
Data Collection
Created
Jul 08 at 04:51pm BST
We're experiencing delays in coverage imports and are working on getting back to normal speeds as soon as possible. Sorry for any delays caused, we'll update when we're back to normal.
Affected services
Application
Data Collection