Back to overview
Degraded

Estimated Views are currently unavailable on new imports

Jul 31 at 03:35pm BST
Affected services
Application

Resolved
Jul 31 at 04:07pm BST

This issue has now been resolved and estimated views will show. Please let us know if you have any clips which are not showing this metric.

Created
Jul 31 at 03:35pm BST

We are currently investigating an issue which is preventing the Estimated Views metric from displaying on new submissions. We will update as soon as this is resolved.