Back to overview
Degraded

Slow Imports

Sep 17 at 05:29pm BST
Affected services
Application

Resolved
Sep 17 at 06:57pm BST

Thanks for your patience while we dealt with this issue. Imports should now process at normal speed.

Updated
Sep 17 at 05:52pm BST

The system is currently working through the backlog, after which you should see imports return to normal. Once again, we are sorry for the inconvenience caused by this issue.

Created
Sep 17 at 05:29pm BST

We are currently working to fix an issue which is causing new imports of coverage to run much slower than usual. We are sorry for the inconvenience caused and are working to restore normal service asap.