The Service is currently unavailable
Resolved
Oct 09 at 06:12pm BST
Our providers system issues are now resolved. We'll continue to monitor for any updates or issues, sorry again if you experienced any issues accessing CoverageBook.
Affected services
Application
Updated
Oct 09 at 02:04pm BST
Our server provider is once again experiencing issues which have taken the app down. We are really sorry for the inconvenience this is causing.
Affected services
Application
Updated
Oct 08 at 06:30pm BST
Our server provider is experiencing issues which have taken the app down again. We are sorry for the inconvenience this is causing.
Affected services
Application
Updated
Oct 08 at 06:26pm BST
The service is now available again but may run slowly as we work through the backlog created by this issue. Thanks for your patience while we get back to normal service!
Affected services
Application
Created
Oct 08 at 06:07pm BST
We're currently investigating an issue which is causing the app to be unavailable. We're sorry for the inconvenience this is causing and appreciate your patience while we work to restore the service.
Affected services
Application