Back to overview
Degraded
Imports running slower than usual
Mar 14 at 03:48pm GMT
Affected services
Data Collection
Resolved
Mar 14 at 04:18pm GMT
The queue has now returned to normal, so imports should be coming through as usual. We're sorry for the delays this caused!
Affected services
Data Collection
Updated
Mar 14 at 04:07pm GMT
We're working through the queue, so data should be coming through now. Imports will continue to be slower while we work through the backlog.
Affected services
Data Collection
Created
Mar 14 at 03:48pm GMT
We're currently investigating an issue which is causing imports and some other features to run much slower than usual. Sorry for the delay and we are working to restore normal service asap.
Affected services
Data Collection