Back to overview
Degraded

Some features are running slower than usual

Jul 03 at 12:54pm BST
Affected services
Application

Resolved
Jul 03 at 01:08pm BST

Thanks for your patience while we resolved this issue, you should now see normal service again.

Created
Jul 03 at 12:54pm BST

We have an issue at the moment which is causing some features to run much slower than usual. We're working to resolve it now and will update as we progress with a fix. We're sorry for any delays this is causing.