Back to overview

Delays in data processing

Sep 01 at 10:50am BST
Affected services
Application
Data Collection
Performance

Resolved
Sep 01 at 03:28pm BST

We're now operating at usual service, so you should see your coverage imports and data start to come through, apologies again for the delays today, if you still require assistance please contact us at support@coveragebook.com and we'll get back to you as soon as we can.

Updated
Sep 01 at 01:20pm BST

We are continuing to work on getting all the data processed to your reports as soon as we can, we are sorry for this delay and will update you as soon as possible.

Created
Sep 01 at 10:50am BST

We're experiencing some delays in processing data, if you have already imported some coverage it will automatically update in your report but may take longer than usual.