Back to overview
Downtime
The service is currently unavailable
Apr 9, 2026 at 1:15pm UTC
Affected services
Application
Data Collection
Resolved
Apr 9, 2026 at 1:20pm UTC
Normal service has now resumed! Thanks for your patience here.
Affected services
Created
Apr 9, 2026 at 1:15pm UTC
Our service is currently unavailable. We are looking into the cause and will update as soon as we can. We're really sorry for any delays this is causing!
Affected services