Issue with metrics summary page not updating
Incident Report for CoverageBook
Resolved
We've resolved the issue where the metrics summary wasn't updating. If you're currently working in a book, refresh your tab to update it. If you have any questions or problems get in touch at support@coveragebook.com and we'll get back to you.
Posted Mar 05, 2021 - 15:42 UTC
Investigating
We're looking into an issue where some metrics summary pages aren't updating. We'll update as soon as we have more info.
Posted Mar 05, 2021 - 15:02 UTC
This incident affected: Data and Metrics.