Problem with password reset & account invite emails
Incident Report for CoverageBook
Resolved
The issue with email deliverability is now resolved. We're sorry if you had any problems earlier today. Please contact support@coveragebook.com if you have any further issues or queries.
Posted 2 months ago. Mar 14, 2019 - 17:50 UTC
Monitoring
We have resolved the issue but will continue to monitor. There is a chance emails relating to new signups, password resets and invites will fail to deliver from the last 12 hours. Please contact support@coveragebook.com if you are seeing any issues relating to this.
Posted 2 months ago. Mar 14, 2019 - 10:47 UTC
Identified
We're aware of some email deliverability issues which are impacting our ability to a few types of message today. That will include password resets & invite emails. We are working to resolve now. Sorry for causing any hassle this morning.
Posted 2 months ago. Mar 14, 2019 - 09:47 UTC
This incident affected: Support.