Issue with books getting stuck
Incident Report for CoverageBook
Resolved
This incident has been resolved.
Posted 9 days ago. Apr 11, 2019 - 16:22 UTC
Investigating
We're investigating an issue with books getting stuck during creation. Data is still being collected in the background as normal. Refreshing your browser should temporarily solve the issue while we're working on a solution.
Posted 9 days ago. Apr 11, 2019 - 16:20 UTC
This incident affected: Image collection and uploading.