Back to overview
Degraded

CoverageBook is performing poorly for some users

May 30 at 03:41pm BST
Affected services
Application

Resolved
May 30 at 06:04pm BST

Our service provider has informed us that a fix has been implemented and we are monitoring the results. Thanks for your patience while this issue was resolved.

Created
May 30 at 03:41pm BST

We are currently investigating an issue where some users are experiencing poor performance while using CoverageBook. This issue is being caused by one of our service providers and we will provide an update as soon as we can. Thank you for your patience while we resolve the problem.